X4 Battery Problems

Commentaires

11 commentaires

  • Logi_Bruce

    Hi Im4theRoyals,

     

    I am sorry to hear that your Jaybird X4 won't hold a charge. This is not the behavior and performance expected from the product. Please try these suggestions that can help to resolve the issue of your headset:

     

    - Computers are the best and safest method, as is anything 1 AMP or less.

    - Try a different power source/charger

    - Car chargers produce a much greater power supply and should be avoided.

    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2 hours,

    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.

    - Avoid charging your headphones after exposure to sweat.

    - Make sure charging port/cradle is clear of any debris.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Actions pour les commentaires Permalien
  • Im4theRoyals

    I have tried all of those, as my post wasn't the first time I've looked at the forum here. I've emailed customer support for warranty assistance.

    0
    Actions pour les commentaires Permalien
  • RASIquitecto

    I got mine replaced for the same issue and the replacement now is dead too! 💀

    0
    Actions pour les commentaires Permalien
  • Chris Roberts

    Lol Jaybird. This is a huge product defect. Everyone I know, including me, has had this same battery drain issues with the X4s and your support is a total joke. You made a defective product but won’t own up to it. It’s a shame because the X4s sound great, but they are nearly worthless with a defective battery. I remember the Jaybird company before they were bought by Logitech...they made quality gear. Now they are just awful. The new more expensive tarah pro and the runs don’t even work with AAC!! They use the basic SBC!! What a joke. You pay way more for a much worse headphone. Ugh. Wish the original owners never sold to the horror show that is Logitech.

    1
    Actions pour les commentaires Permalien
  • Debbie Bain

    I’m on my second pair of X4’ s. My first died after about seven months because the battery wouldn’t hold a charge. The replacement pair lasted less then a month due to the same problem. Obviously an inherent product problem. No more Jaybird products for me. Going to try the Bose SoundSport next. Good by Jaybird.

    0
    Actions pour les commentaires Permalien
  • miko pena

    Hi only 3,months and i already have this issue! I bought my x4 in Singapore but i live in the Philippines os there any support you can offer?

    0
    Actions pour les commentaires Permalien
  • William Thomas

    The Jaybird headphones only last 7 months. Even with following all the recommendations between my family we have owned 7 pairs total none of them have gone over 7 months without a battery issue.

    1
    Actions pour les commentaires Permalien
  • Jonathan Yehie

    I've had the x3 which died on me and now the x4 which now lasts for about 3 hours maybe less.

    I find it ridiculous that in this day and age they tell you to limit the charge, as if you forget it for another hour and the product is ruined.

    I agree with all of the other comments.
    Starting to feel like a ripoff.

    0
    Actions pour les commentaires Permalien
  • Iger

    Hi,

    I also have X4 about 9 months and i have the same issue, i also had this issue in my previous X3.

    I don't really understand why Jaybird charges ~100$ for this crappy products??? you don't do QA for you products???

    this is defiantly the last time i buy Jaybird products, now i'll move to plantations!

      

    0
    Actions pour les commentaires Permalien
  • Jens Peter Jensen

    I have exactly the same problem. Mine are about 1 month old and they have been great up to yesterday. This morning they lost their entire charge in 20 min! They just turned off. They really worked so well until yesterday!!!! 

     

    0
    Actions pour les commentaires Permalien
  • Karel Vermeulen

    My problem started about 2 weeks ago and thought I'm going mad. After 5 min charge the lady "promptly" stated...battery 80%. A couple of minutes later the unit does not even turn on.

    After all comments left in the past 12months, no feedback from support???? This is BAD!

    Very sad about the earphones, worked great when they were working...Will def move to another brand!

    0
    Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.