Right Earbud stopped working!

Comments

10 comments

  • Hazal Tural

    Hi,

    Hope you can solve your issue soon. 

    My left bud also stopped working today. I tried every reset options shown on the webpage but one bud is still unresponsive.

     

    Help!

     

    2
  • James Brewster

    The exact same issue. 

    A friend's vista's have also done the same :/

    1
  • anshul patel

    exactly same issue in my right bud .. what to do ?

    2
  • David Keneford

    Same issue. Tried the reset options. Would hate to have to replace after just about 1 year. Not cheap.
    Question: could it be sweat getting into the buds? I use them biking and working out.

    2
  • Royce Greiner

    Guys I’ve been reading the threads of other vista owners with the same issue. They came to the conclusion that it was a software update that is to blame.

    2
  • Shane

    These threads go back 16 or more days - has anyone's issue been resolved? I haven't seen any comment from support.

    1
  • Asher Gale

    Agreed. Support isnt replying to my issues either.

    3
  • Skyler Sommer

    Same story with my pair, and no response from support. 

    2
  • Shane

    Not sure if it will help everyone but I turned auto-off "off" and left my buds out of the case overnight so they would drain completely. I then went into all of my devices and deleted or forgot my Jaybirds in the Bluetooth settings. I put both buds into the case with the case plugged into my computer for power. Once they were fully charged I did a factory reset and re-paired to my devices. This fixed it for me and my earbuds are back to working as usual. 

    -2
  • Skyler Sommer

    Unfortunately that is not the problem that the majority of us on here are facing with our buds not playing sound. I have addressed any settings in the app that might affect the bud. I can see the battery on the bud and verified that it is charging. I can even play / pause and change the volume with the controls  on the bud that isn't playing music (the other one plays fine). I can change these functions from the app, but that doesn't allow the bud to play sound. It is indeed connected, and charged. There are no physical obstructions of water or some other material in the device keeping it from playing. 

    It seems like it is software related by the nature of so many people on here having the same problem all of a sudden. 

    2

Please sign in to leave a comment.