Charging case not charging earphones or pairing to device.

Comments

3 comments

  • Official comment
    Logi_Bruce

    Hi Jai/Kritin,

    Thank you for reaching out. I'll be happy to help you with this one.

    I listed some of the things I'd like you to try:

    Kindly try using a different power source/charger and/or a different USB cable. A pulsing green LED on each side means it is charging, solid green light when fully charged. It is recommended to use 5V/500mA-1A charger for 2 hours only.

    It would also help to ensure that the lid of the charging case is securely closed and the charger ports and prongs align accordingly and are free from debris.

    Lastly, you can reset the buds by following the steps found here:

    https://www.jaybirdsport.com/en-us/jaybird-support/jaybird-vista/faq/troubleshooting/how-do-i-reset-my-earbuds.html

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Kritin Kapur

    This has happened to me today as well. Additionally, the left ear bud seems to charge but the right does not

    0
    Comment actions Permalink
  • Jai Bakshi

    Hi,

    It still doesn't work I've tried everything, I also cannot factory reset the earphones the case light does not blink and is unresponsive.

    0
    Comment actions Permalink

Please sign in to leave a comment.