X4's working, but cant charge!

Comments

10 comments

  • Official comment
    Logi_Bruce

    Hello Yew Jin,

    Thank you for reaching out. I'll be happy to help you with this one.

    Sorry for any confusion. Please use a charger that has 1A to 1.5A current as output and check if that helps fix the issue. I'd love to hear your thoughts as well, so if this works, please let me know.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Jesse Fallis

    I’m having the same issue. Only recently did this start happening. I’m wondering if it’s the charger itself? Mine are less then a year old, they have been great till now but this is really annoying

    0
    Comment actions Permalink
  • Yew Jin Toh

    I suspect its the contact pads on the X4's. Mine looks like they've been worn out till the charging pins on the cradle wont have any contact. Its as though they're made of foil which wore off till I can see bare grey plastic of the mic. Does yours look like they've been worn out as well?

    0
    Comment actions Permalink
  • Jesse Fallis

    The contacts on my x4s look like they are in good shape. Slight wear but nothing crazy.

    0
    Comment actions Permalink
  • Jesse Fallis

    Could the springs behind the pins in our charging cradles be weak not allowing them to push hard enough against the contacts on the headset?

    0
    Comment actions Permalink
  • Yew Jin Toh

    Hi Bruce,

    I've tried connecting to a 1A adapter, still can't charge. Can definitely feel the cradle snap snuggly into place so contact should be fine.
    I do notice the contacts on the mic look like it's been worn out. One patch looks as though it's grey plastic at the bottom. I can send a pic if you like.

    0
    Comment actions Permalink
  • kelsey meggison

    I’m also having the same issue as of today after I updated the app on my phone.

    0
    Comment actions Permalink
  • Yew Jin Toh

    Means yours can't charge after updating the app on your phone? That's very weird behaviour

    0
    Comment actions Permalink
  • Yew Jin Toh

    Update:
    I've sent my pair in for warranty to Logitech on 19th June. Sadly they've rejected it since my warranty expired on 8th May 2020.

    The kicker is...i first got this problem at around early March this year, just when we all entered lockdown due to Covid19! There's no way I could send mine in before the expiry date since we've only just recently loosened the lockdown rules. Currently trying appeal via their customer service hotline :(

    0
    Comment actions Permalink
  • Yew Jin Toh

    Hi Bruce,

    I have a querry on the warranty policy of Jaybirds/Logitech products. If the warranty of a product expired during extraordinary circumstances eg Covid19, can it be extended?

    Or is there any email I can send this querry to?

    Update:
    Jaybird customer service has replied saying they only provide troubleshooting support, not warranty related support. They advised to go back to the point of purchase to escalate it... Except my point of purchase already tried escalating to Logitech too and was rejected. I'm being led round in circles now.

    0
    Comment actions Permalink

Please sign in to leave a comment.