Jaybird X2 Trouble Bluetooth connection xfinity x1

Comments

1 comment

  • Official comment
    Bruce

    Hello Serpent11,

    Thank you for reaching out. I'll be happy to help you with this one.

    There are several things to consider when this sort of problem arises:

    -Did you change update anything on your phone/other devices?

    -Are the buds' (X2) specifications compatible with that of your device?

    -Is there room for your devices to discover the buds? Please note that Bluetooth lists have a limit of the number of devices it can remember

    -Do you get any error when attempting to connect?

    -Do you get the same problem when you try to connect the buds to other device/s or a device with a different OS?

    -You can try resetting the buds, here are the steps:

    1) Turn headphones off 
    2) Put headphones in pairing mode (hold middle button for 6-8 seconds until it says, "Searching for your Music Device")
    3) LED will flash red and green 
    4) Hold both volume buttons down 6-8 seconds, this will reset the headphones
    5) LED will flash orange 3 times 
    6) Delete Bluetooth profile from device 
    7) Put headphones back into pairing mode and connect them to your device. 

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink

Please sign in to leave a comment.