Jaybird vista Right earbud is malfunctioning after update

Comments

9 comments

  • Official comment
    Bruce

    Hello there,

    Thank you for reaching out and I am sorry to hear about what happened, let me help you.

    I've sent you an email with details on how we will proceed with this one.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Timothy Hill

    I am having the same issue after updating my device.

    1
    Comment actions Permalink
  • poop

    No solution so far

    0
    Comment actions Permalink
  • Bruce

    Hi Timothy,

    Thank you for updating this post.

    I also sent you an email with regard to this concern. Through the said ticket, we can get more information as well.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    0
    Comment actions Permalink
  • Timothy Hill

    Right ear bud does connect to my phone but audio is almost nonexistent. I have to play with the position of the ear bud to get it to work. It constantly cuts in and out. I apologize for the delayed response.

    1
    Comment actions Permalink
  • Timothy Hill

    What is being done to rectify the firmware on my $200 paper weight?? I would love to be able to listen to my music while I’m disc golfing without connection issues.

    0
    Comment actions Permalink
  • Bruce

    Hello Timothy,

    Thank you for the update.

    Please check your email for a follow-up on your open ticket.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    0
    Comment actions Permalink
  • Timothy Hill

    I’ve done everything on my end to try and mitigate this situation or else I would not be reaching out. Factory reset doesn’t work. It has something to do with the firmware update because they worked fine before the update.

    0
    Comment actions Permalink
  • Timothy Hill

    Is anything being done to fix this issue??

    0
    Comment actions Permalink

Please sign in to leave a comment.