Can't update to the latest (v1.1.16) firmware.

Comments

7 comments

  • Official comment
    Bruce B.

    Hello Rasmus,

    Thank you for reaching out. I'll be happy to help you with this one.

    I agree with Chris' suggestion. Let's reset the Vista's and see if that will fix the issue.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

  • Christopher7758

    I would try a hard reset of the buds then try again if you haven't already.

    Complete a factory reset of your earbuds

    Before starting this process please “FORGET” or “REMOVE” your Jaybird Vista device from the Bluetooth menu on all your connected audio devices.

    Place both earbuds into the charging case and close the lid.

    Open the charging case. Press and hold the case button until the case LED starts blinking white.

    While the charge case LED is blinking white, press the case button twice.

    The LED will blink pink and you can now close the case.

    When you open the case, your earbuds are reset and ready to pair. Go to the Bluetooth menu on your audio device and select ‘Jaybird Vista’ to pair again.

    Remember to reselect your favorite preset from the Jaybird App.

    0
  • Eric Déziel

    I have the same problem. The buds are brand new, out of the box and the update won't work and stops at 15%. Why am I supposed to factory reset brand new buds ? Or perhaps they are not really new... But it's a chance they won't update with this update mess. I would just like to know how I can stop the update nag screen to appear.

    0
  • Jonathon Heron

    I have the same problem. 15% and then "Something went wrong" message brand new trying to update to v1.1.6. Tried the steps above to no avail. Please can somebody advise. Agree with Eric that this is not really acceptable for a brand new out of the box product. Thanks. Jon

    0
  • Aneel Kabir

    Just got mine today in the mail and I have the same exact issue.

    0
  • Tim Keijzers

    Same issue here. And factory reset did not solve the problem. Update stops at 15%.

    0
  • Dave G

    Exactly the same problem here.

    0

Please sign in to leave a comment.