Jaybird Vista keeps disconnecting when using with MacBook Pro

Comments

8 comments

  • Official comment
    Logi_Bruce

    Hi Mustafa,

    Thank you for joining the community and for posting your query. 

    I believe the issue is isolated only with the MacBook Pro since you mentioned that there are no issues with your other Jaybird buds. I highly suggest to contact Macbook Pro/Apple Support.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • RachaelBouissey2338

    I’m having this exact same problem. Never used Jaybird before and just bought Vista. They work perfectly on my iphone and my pc, but disconnect from my macbook pro (2018) after a couple minutes. I needed them for work so I actually might have to return them.

    If OP used other Jaybirds with their same macbook pro, and they were fine, it sounds like it’s actually a problem with the new Vista model. Their computer hasn’t changed but the Jaybird has.

    1
    Comment actions Permalink
  • Josh

    I am having the same problem with my 2018 MacBook Pro as well.  They connect fine to my iPhone but keep disconnecting over and over on the MacBook.  Super annoying.

     

    Also annoying, Bruce's suggestion to contact Apple.  It is clearly a Jaybird problem, not an Apple issue.  These buds have had connectivity issues from the get go.

    1
    Comment actions Permalink
  • TE San

    Also annoyed by that response... This is happening to me with my Macbook Air. These are expensive headphones which clearly were not intensively quality assured before going to market. This is clearly an issue between apple macbooks and the jaybird, it is OBVIOUSLY not exclusive to the macbook. 

    1
    Comment actions Permalink
  • RachaelBouissey2338

    I solved the issue. Hopefully it will work for the rest of you. 

    If you have the jaybird app there are troubleshooting steps, including a reset. I started having major issues beyond disconnecting from my macbook so I tried it. I had to reset a few times, might have been doing it wrong, but now it works for the most part. Currently my issue is that it will randomly disconnect. It happens rarely and I might try another reset to see if that fixes it. Honestly I'm surprised the official response didn't suggest this.

    I just looked at the app again and apparently there's a firmware update so you might try that too!

    -1
    Comment actions Permalink
  • Callumph

    I have this issue too. My Vista's work perfectly with my iPhone and iPad, but drop out every couple of minutes when connected to my 2019 MacBook Pro running 10.15.4. I have tried all of the reset options and the issue persists. 

    I contact Jaybird support and they told me to contact apple as well. None of my other bluetooth headphones have this issue when connected to my MacBook, only my Vistas.

    Jaybird - do you have any further support to offer for this problem?

    1
    Comment actions Permalink
  • Dunal Riveland

    I have this exact issue and had the earbuds swapped 2 times... I was told the exact same thing... Even thought I told them multiple times... I knew others had this issue I was informed that mine was an "isolated issue" - it is not and it renders these 180$ earbuds essentially useless to me. I am studying and they regularly disconnect causing my computer to blast whatever im listening to into a quite study hall or public... It is spontaneous and unpredictable... "Resetting" and "Rebooting is a bit of a foregone conclusion" as most people who use these grew up in tech age -  its likely we have all reset/ rebooted/tried to "re-something". This doe snot fix the issue and my 2018 Macbook Pro like others is nothing to scoff at. Thats the top brand/notch quality and I would expect that of all things... you would maybe want your product to work with the most sought after laptop...

    I was told to try to "reset" lol of coarse I knew this did nothing. - I am curious about another "firmware" however I have reinstalled and called in and done this a few times... This is the only product out of 40-50 things (mostly audio devices) which I have had problems connecting with... Most of the time it is a seamless connection. With the Jaybird vista - they are actually useless in public as the disruption created too many problems... annnnnnd public is where these are used. When I first asked I was told my issue was isolated..... this is clearly not the case... on apples end. there is nothing unique to Jaybird which apple has any knowledge or control of.

    This is hardware/compatibility/firmware/something with design. It is almost solely a Jaybird thing... It is unfortunate - because until this became an issue I had perceived Jaybird to hold the best customer service that i've seen. After spending a-lot of time and waiting multiple times... it seems I was not told the whole truth... I wish they would rectify this.

    1
    Comment actions Permalink
  • Dunal Riveland

    2 Replacements and Multiple Hard resets and soft resets... This is stated as a "MacBook Pro" issue... The Jaybird Vista is the only one with the problem... All other devices work just fine,,, Jaybird Vista disconnects regularly, even used as directed... only 1-2 feet from computer.... I am starting to think - (knowing Logitech) that this issue could have to do with Jaybird attempting to collect data through end user devices... whether or not it is explicitly stated. Apple - particularly the 2018 MacBook Pro and higher have little more advanced security system then other apple products... This is most certainly integrated into what is being communicated with and through the MacBooks bluetooth... but this would ONLY be an issue if there was some sort of "non-transparent" process, like a. data pull. Or dedicated memory outside of the primary task. - Worth mentioning as I spoke with a specialist regarding things things. I am certain some representative will try to curtail this into looking like (A) I am exaggerating... or (B) just plainly state that this is not true... But it seems to be the case... persistent issues with specific earbuds... and particularly when they interact with devices that dont allow background data gathering passively... repeated attempts by a plethora of people saying the same thing including myself and only now finding out that this issue is floridly abundant in the community.

    1
    Comment actions Permalink

Please sign in to leave a comment.