Jaybird Vista keeps disconnecting when using with MacBook Pro

Comments

5 comments

  • Official comment
    Bruce

    Hi Mustafa,

    Thank you for joining the community and for posting your query. 

    I believe the issue is isolated only with the MacBook Pro since you mentioned that there are no issues with your other Jaybird buds. I highly suggest to contact Macbook Pro/Apple Support.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • RachaelBouissey2338

    I’m having this exact same problem. Never used Jaybird before and just bought Vista. They work perfectly on my iphone and my pc, but disconnect from my macbook pro (2018) after a couple minutes. I needed them for work so I actually might have to return them.

    If OP used other Jaybirds with their same macbook pro, and they were fine, it sounds like it’s actually a problem with the new Vista model. Their computer hasn’t changed but the Jaybird has.

    0
    Comment actions Permalink
  • Joshua Jackson

    I am having the same problem with my 2018 MacBook Pro as well.  They connect fine to my iPhone but keep disconnecting over and over on the MacBook.  Super annoying.

     

    Also annoying, Bruce's suggestion to contact Apple.  It is clearly a Jaybird problem, not an Apple issue.  These buds have had connectivity issues from the get go.

    0
    Comment actions Permalink
  • TE San

    Also annoyed by that response... This is happening to me with my Macbook Air. These are expensive headphones which clearly were not intensively quality assured before going to market. This is clearly an issue between apple macbooks and the jaybird, it is OBVIOUSLY not exclusive to the macbook. 

    0
    Comment actions Permalink
  • RachaelBouissey2338

    I solved the issue. Hopefully it will work for the rest of you. 

    If you have the jaybird app there are troubleshooting steps, including a reset. I started having major issues beyond disconnecting from my macbook so I tried it. I had to reset a few times, might have been doing it wrong, but now it works for the most part. Currently my issue is that it will randomly disconnect. It happens rarely and I might try another reset to see if that fixes it. Honestly I'm surprised the official response didn't suggest this.

    I just looked at the app again and apparently there's a firmware update so you might try that too!

    0
    Comment actions Permalink

Please sign in to leave a comment.