Cannot update firmware on Tarah Pro.

Comments

2 comments

  • Official comment
    Bruce

    Hi Wout,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    NOTE: Make sure that your audio device is compatible with the Jaybird App. The Jaybird App runs on devices using iOS 11 and above and Android 6 and above.

    If you’re having issues updating your Jaybird Tarah Pro firmware, the earbuds might not be making the appropriate connections. Please check the following:

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Wout Schutz

    Hello Bruce,

    I'm running Android 9 on a Samsung Galaxy S8. The earbuds are fully charged. The earbuds are obviously connected, otherwise it wouldn't give me notifications that its firmware needs an update, or allowing me to tap "Install update" for the Tarah Pro in the first place... I'm not sure if this was an automated response.

    I hope you'll get back to me.

    Best regards.

    0
    Comment actions Permalink

Please sign in to leave a comment.