Jaybirds won't charge

Comments

4 comments

  • Official comment
    Logi_Bruce

    Hi Wanda and Matthew,

    Thank you for reaching out. I'll be happy to help you with this one.

    I listed some of the things I'd like you to try:

    Kindly try using a different power source/charger and/or a different USB cable. A pulsing green LED on each side means it is charging, solid green light when fully charged. It is recommended to use 5V/500mA-1A charger for 2 hours only.

    It would also help to ensure that the lid of the charging case is securely closed and the charger ports and prongs align accordingly and are free from debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Matthew Leitch

    I have the same issue and mine are a week old...HELP!

    0
    Comment actions Permalink
  • Wanda Mitcham

    Hi Mattew,

    Did you get the problem with your earbuds resolved because I haven't?

    0
    Comment actions Permalink
  • Yasar Arafat

    Take the earbuds out the case one by one and see and put them back in one by one. See if each the cradle lights up with each one. If this is not the case for one or both, check the case. See if those copperlooking points arent bent in any way. One of my buds wouldnt charge because i bent the chargingpoints taking them out. I bent these back with a pair of small tweezers,

    0
    Comment actions Permalink

Please sign in to leave a comment.