Left earbud stopped working properly

Comments

8 comments

  • Tim Korver

    Same happent to me, but both earbuds are not working. Did a soft and hard reset and updated the app. Nothing worked.

    0
    Comment actions Permalink
  • Kyle

    Having the same issue with the right earbud. Contacted Jaybird and awaiting response.

    0
    Comment actions Permalink
  • Tim Korver

    Are you guys using Iphone as well?

    0
    Comment actions Permalink
  • Kyle

    No android but also connect to iPad

    0
    Comment actions Permalink
  • Tim Korver

    Strange, i am using iphone, but connected to my laptop and they were both working.

    0
    Comment actions Permalink
  • Fredrik Lundgren
    Hi bought a couple of vista in the belief that you could train with them and even sweat, the headphones sit really good and good sound, but the thing is that the left headphones sometimes stop working quite often, when you solve this you have paid 1900 sek, they are after all, totally worthless, I paid for the sound of both not only the one, solve this immediately

     

    0
    Comment actions Permalink
  • Ben Jones

    Have had the same problem with the left earbud. Connectivity is a problem and the bud won't charge in the case. I have a pending firmware update but the left bud has less than 10% battery so I'm unable to update it from the app...

    0
    Comment actions Permalink
  • john fotouhi

    I am having the same problem. The left bud won't charge in the case, and has no battery left. When I put the right earbud in the charging case, I can hear a whining noise when I hold it up to my ear, indicating that it is charging. However, when I put the left bud in the case I can't hear the noise. Also, the white light doesn't blink to indicate charging like it usually does. I've tried resetting it and cleaning the charging ports.

    0
    Comment actions Permalink

Please sign in to leave a comment.