Jaybird X4 Suddenly Quit Working

Comments

3 comments

  • Emily Eylon

    This same thing happened to me last night and is still continuing today.

    0
    Comment actions Permalink
  • Steven Rittenberg

    My X4, showed charged then died just a couple of days ago. They were working just fine then all of a sudden they seem to have completely failed. 

    I have performed a factory reset and will perform a firmware update shortly.  

    On the chance they do connect the phone app has shown a charge of 100% and it works for a bit. If the phone shows 70% they disconnect and I have to reconnect to the charger to get them to work again.  This only works up to 60% charge then they are dead.  

    During a charge, (via computer or a low amp charger) the light never goes green, it stays red.  Additionally, when connected I was having it intermittently disconnect.  

    I received these in August to replace a pair of X3's that no longer held a charge.  

    Hopefully, someone from Support can provide some direction on this issue.

     

     

     

    0
    Comment actions Permalink
  • Steven Rittenberg

    Providing an update since the firmware update.  I had a 100% charge at the time of the firmware update, 3 hours later with the headphones turned off the charge is now at 60%.  I am guessing that they will be dead come morning for a workout.  

    Obviously there is something flawed with the product as I have seen many posts recently on this forum related to X4 units suddenly no longer holding a charge, not charging or becoming non-responsive.  

    Support recommends not to charge for more than 2 or 2.5 hours, as well I had been advised to use a computer to charge them not a phone charger as the amperage would be too high.  I have been using a charger that is rated at less 1 AMP but still have this issue.  For the price of these headphones, it is disappointing that I have not been able to get a full year of use out of these or the original unit I had purchased.  

     

    0
    Comment actions Permalink

Please sign in to leave a comment.