The charging box lights off while charging and the middle light blinking red after charging

Comments

2 comments

  • Official comment
    Bruce

    Hi Rico,

    Thank you for reaching out. I'll be happy to help you with this one.

    I listed some of the things I'd like you to try:

    Kindly try using a different power source/charger and/or a different USB cable. A pulsing green LED on each side means it is charging, solid green light when fully charged. It is recommended to use 5V/500mA-1A charger for 2 hours only.

    It would also help to ensure that the lid of the charging case is securely closed and the charger ports and prongs align accordingly and are free from debris.

    You should be able to charge your buds two (2) or more times when your charging case is fully charged.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Rico Lee

    Hello,

    I would like to say all your suggestion is not working. (* My earbuds are fine, it's just my charginf case is not working!)

    Right now, I can't even charge my earbud and charging case, everytime the second I plug the cable to the charging case, the lights are off, and the second I unlpug the cable, there's a solid red light is on for the middle light, and both charging case and earbuds are not working, please help with it, I just bought this earbud for like one year and few months, thank you so much.

    one more thing, I can't use the firmware too, I plug the charging case to computer while the firmware is on, the firmware/ computer can't detect my charging case/ earbud...  (the firmware is up to date, I tried like 3-4 cable, all cable is working perfecting with other devices)

    0
    Comment actions Permalink

Please sign in to leave a comment.