Bluetooth

Comments

1 comment

  • Official comment
    Bruce

    Hi Anngun,

    Thank you for reaching out. I'll be happy to help you with this one.

    You can definitely connect your Vista with your IPhone without any issues as Bluetooth 4.0 is compatible to Bluetooth version 5.0 and higher.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink

Please sign in to leave a comment.