Vista only lasting 2.5-3 hours (brand new, btw)

Comments

2 comments

  • Official comment
    Bruce

    Hi Jonathan,

    Thank you for reaching out. I'll be happy to help you with this one.

    I listed some of the things I'd like you to try:

    Kindly try using a different power source/charger and/or a different USB cable. A pulsing green LED on each side means it is charging, solid green light when fully charged. It is recommended to use 5V/500mA-1A charger for 2 hours only.

    It would also help to ensure that the lid of the charging case is securely closed and the charger ports and prongs align accordingly and are free from debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Jonathan Advocate-Ross

    Bruce, you do realize my post was referring to the Jaybird Vista, right? (Hence the name Vista in my initial statement above.) Unless I'm completely unaware of some green lights on the case or the buds themselves all I see is one white light (LED) on the charging case. Just to confirm, I understand that it is still charging when the light is still pulsing in and out as well as finished charging when it stays a solid white (no pulsing). (Already checked to make sure they were connected to the prongs in the case, clean no debris, etc.) The model you were thinking of was probably the Jaybird Run, now if you could get me some advice/solutions regarding my issue to the Jaybird Vista (not Run) it would very appreciated. 

    0
    Comment actions Permalink

Please sign in to leave a comment.