Bricked RUN xt with firmware update

Comments

3 comments

  • Official comment
    Bruce

    Hello Nicholas,

    Thank you for reaching out. I'll be happy to help you with this one.

    Glad you were able to sort it out. This will be very helpful to other community members.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Nicholas Thorn

    *edit

    Happily - I eventually managed to get it to work.  I don't know if it was coincidence but after playing around quite a lot more fiddling with the case/removing bumper/holding case closed I eventually got it detected it as USB Left Earbud and the firmware update worked this time.

    Hopefully this helps anyone else who might have problems!

    0
    Comment actions Permalink
  • Rick Tan

    I also having problem updating the firmware from the beginning due to the firmware download site keeps downloading the Run firmware instead of the XT. I'm very sure I went to the XT firmware to download. After many tries then able to download the correct version Jaybird_1.8.0_x86_release_RUN_XT_1.1.6_Nov2019. Worried the upgrade process will gave me problem but to my surprise everything went smoothly. I'm updating the fw due to the left earbud keeps disconnecting hope the new firmware will fix the problem. Not sure what are bug-fix introduced in the 1.1.6 version? Hope Jaybird keeps improving their product quality and performance.  

    0
    Comment actions Permalink

Please sign in to leave a comment.