Tarah Pro won’t turn on

Comments

7 comments

  • Official comment
    Bruce

    Hello Roberth and Christina,

    Thank you for reaching out. I'll be happy to help you with this one.

    I want to know if you have tried these recommendations:

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Christina Pitner

    I’m having the same issue. Only way to get it to connect is being on the charger. Nothing I’ve found online fixed this.

    0
    Comment actions Permalink
  • Roberth Karman

    Bruce,
    I have tried to charge using different USB-ports on my laptop. The headphones charge fine in all of them and when they are turned on (with the USB charger connected) they report charge level to my phone (first attempt they were at 40%, second attempt they had charged to 58%).
    The problem is not charging - the problem is that they turn off as soon as the USB charger is disconnected and they are then unable to be turned on.

    0
    Comment actions Permalink
  • Christina Pitner

    Hi Bruce,

    I'm experiencing the similar issues as Roberth. I can charge just fine, have used different ports on my laptop, never use a car charger to charge. I'm able to pair to my phone only when the headset is plugged into the laptop. Once its connected, I can keep it on but if I disconnect for any reason, I'm not able to connect again unless plugged into the laptop.I can't even get them to power on unless connected to the laptop. Please help!

    0
    Comment actions Permalink
  • Ian McBeth

    same issue here.   light comes on, when on cradle... However cannot seem to turn them on :( 

    1
    Comment actions Permalink
  • Rudyard Vega

    Same problem. They do nothing even after trying all ways of reset. Disappointing. How can I get my money back?

    0
    Comment actions Permalink
  • Dale Doucet

    I exchanged my first set that was doing this, the second set is acting the exact same way. Both sets were purchased at Best Buy... very disappointed in $170 headphones working less than a month.

    0
    Comment actions Permalink

Please sign in to leave a comment.