Update problem with version 1.4.2



  • Official comment
    Bruce B.

    Hello Ian,

    Thank you for reaching out. I'll be happy to help you with this one.

    Sorry for any confusion. For Jaybird Freedom, the latest firmware version is 1.3.2. To start the update, the buds need to sit on top of the charging clip but not "clipped"; clip needs to be plugged onto the computer, once you're ready to update, press down on the power button of the Freedom allowing it to clip onto the charging clip. This will initiate the update.

    For the full instructions/more information, please go here:


    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird Customer Experience

  • Randy Sengbusch


         I am having the same problem V1.0.4 and i cant get it to update at all, probably tried to connect it to the charging dock to get update to start and nothing.the website says current version for software is 1.4.0 I am trying to fix only having one ear bud working, i know its probably not going to fix it but i wanna get it checked off the have you tried this list before i get in contact with customer service.


Please sign in to leave a comment.