Right earbud volume issue - Jaybird Vista

Comments

8 comments

  • Official comment
    Bruce

    Hello Ali,

    Thank you for reaching out. I'll be happy to help you with this one.

    Kindly try and update the buds' firmware as this will help fix this. You can find the firmware update instructions here:

    https://www.jaybirdsport.com/en-us/jaybird-support/jaybird-vista/faq/general/how-do-i-update-my-jaybird-vista-earbuds.html

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Yohannes Belachew

    I'm experiencing the exact same issue. I'm on firmware 1.1.5 and jaybird v3.6.6 software

    0
    Comment actions Permalink
  • Robert BeDell

    @ Yogi Nonya I created another thread. Same here but mine is the left headphone same firmware version and app version build 417. Any luck?

    0
    Comment actions Permalink
  • Yohannes Belachew

    Nope, waiting to see how support will address this issue. I read another thread where they say they rectified volume imbalance with a firmware update, but this is starting to look like a hardware issue. If you're using android and have a rooted phone, look into ViPER4Android FX which lets you (among other sound improvements) dial in the left & right channel to even the volume. Thats the only temporary fix I've come across.

    0
    Comment actions Permalink
  • Robert BeDell

    I have a Note 9 Snapdragon so root is unavailable unfortunately although I'm familiar with the mod. The firmware article I saw referred to months ago though so I'm guessing around the original release. It makes me wonder if they fixed it and then accidentally reintroduced the bug in an update. Didn't do this on V1.1.4. wish there was a way to roll back or a factory reset would remove updates. This kinda sucks. I have until Jan 14th to return it so I'll probably give it a little longer before I swap to a different set.

    0
    Comment actions Permalink
  • Yohannes Belachew

    Can't remember when I made the firmware update..here's hoping they actually fix the problem as these are by far the best wireless sports iems I've owned. The responsiveness in terms of support from jaybird however leaves much to be desired! Hope it gets sorted out for you as well, mate.

    0
    Comment actions Permalink
  • Ali Farag

    I was contacted and I received a replacement bud but the problem wasn't solved. The left bud works normally and the new right bud either doesn't work or just makes cracking noises. I checked the app and there wasn't any firmware update (currently on Jaybird v3.6.4 Firmware v1.1.5). I don't understand what the problem is exactly since the I just received the new bud today.

    0
    Comment actions Permalink
  • Kevin N

    I am having the same issue.

    I am on app version 3.6.6 and firmware version 1.1.5.

    I returned the new Vista's at best buy for a new set. Charged for 1 day and watch videos for 3 hours. Left side battery drainage appears to be resolved but the right earbud is draining significantly more. Problem is reversed now. Plus some crackling sound sometimes. Hmm... Jaybird are these worth almost 300 dollars. Ugh...

    0
    Comment actions Permalink

Please sign in to leave a comment.