Unable to start after charging

Comments

3 comments

  • Official comment
    Bruce

    Hello Keith and Johan,

    Thank you for reaching out. I'll be happy to help you with this one.

    You can also follow these recommendations:

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Keith Czechmeister

    My Tarah Pro's are 11 months old and I'm having the same issue. it appears to be charging but when I attempt to turn them on and use them they are not responding. No LED light even after trying to factory reset. 

     

    Where or how do we get our hands on the warranty. The online info. has little to go on. 

    0
    Comment actions Permalink
  • We-sen Chew

    Hi Admin, 

    Riding onto Johan's post, i'm having the exact same issue with my Tarah Pro. 

    Mine is about 2-3 months old. It was fine the previous day. Charge it, white LED was on. Detach from charger and it's dead. Tried all the recommendations but to no avail. 

    I second Keith's comment above. Online info is limited on warranty issue. 

    Please advise. 

    Thanks.

    0
    Comment actions Permalink

Please sign in to leave a comment.