Not charging - 3 days old - EXPENSIVE product

Comments

3 comments

  • Official comment
    Bruce

    Hello Byron,

    This definitely shouldn't be happening but I appreciate you reaching out.

    I'd like to learn more about your concern. You mentioned you have tried the troubleshooting steps, can you share what you did so we'll know if you missed something.

    Thanks in advance.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Jennifer Frahm

    I’m having the same issue! I’ve tried several reset options, but I can’t even get the LED to come on. I’ve tried calling twice and sent a message to tech support, but I haven’t been able to reach anyone for help.

    0
    Comment actions Permalink
  • Andrew parkes

    Awaits the standard copy paste response and then nothing no doubt. One reply i have had in over a week, really is god awful customer service and even more awful product. The amount of issues this product seems to have is unreal, the forum is littered with problems, mostly the same, if they had any sense they would be recalling these things

    1
    Comment actions Permalink

Please sign in to leave a comment.