My Jaybird x4 stopped working

Comments

7 comments

  • Official comment
    Bruce

    Hello Laurent,

    Thank you for reaching out and posting your query. I'll be happy to help you with this one.

    Can you try and restart your IPhone prior to re-pairing? Please allow the IPhone to be on an off state for ten (10) seconds or so before you turn it back on.

    As for the app, you can uninstall and re-install the Jaybird App. You can further isolate the issue by connecting your buds to a different device or a device with a different OS.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Grant

    Same here..started with the left earbud, now it cannot even be re-paired to my i-phone. Attempted re-starting, factory reset, everything. Must be a manufacturer defect as I am seeing many others with the same issue. I've reached out to support and hoping someone can get back to me while it is still under warranty. 

    0
    Comment actions Permalink
  • Gilles Breton

    Same problem for me. Jaybird X4 just stopped working. Bought in June. First they where dropping connection, now they just don't gets on. Very disappointing.

    0
    Comment actions Permalink
  • Jeffrey Dore

    First pair of x4 died, did all the steps they warrantied them and alas today two months in my warrantied pair did the same thing. Can’t even turn them on or reset them because they are bricked. WTH has happened to Jaybird? For the cost, this shouldn’t be a problem.

    0
    Comment actions Permalink
  • Laurent Nguyen

    tried everything that was suggested, nothing. Impossible to pair. it seems the device is completely dead...no shock, normal usage for a sports device....very disappointing first experience with the brand. 

    0
    Comment actions Permalink
  • Gilles Breton

    Hi,

    Just decided to buy Apple Airpods Pro. They will work more than 4 months.

    For the record, if I long press the center button, at least 30 seconds, eventually the green light shows up (this does not work all the time, sometimes I need to try many cycle of 30 seconds or more to get the reenlisted light...).

    Still holding the center button, 10 seconds later, the pairing red-green light flashes. I pair to my iMac. It connects for 2 seconds then disconnects. The X4 have shut down. Nothing more.

    One could blame Catalina or IOS 13.2 but not getting the green light after pressing 2-3 seconds as they used to when they were new and setting down right after successful pairing is not normal.

    0
    Comment actions Permalink
  • Ahsun Saeed

    I'm having the exact same issue. Have been extremely gentle and careful with my earbuds and they haven't had any issues until now where they simply will not pair with any device.

    0
    Comment actions Permalink

Please sign in to leave a comment.