Freedom don't turn on, battery fully charged

Comments

4 comments

  • Official comment
    Bruce

    Hi MB,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    Please try these suggestions that can help to resolve the issue of your headset:

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2.5 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    You can also try to turn the buds on while attached to the charging clip---and plugged to a power source.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Marie

    Sorry Bruce, still doesn't work. Had seen the post before and did the process of loading, etc. It was always loaded with the computer. How can the battery be checked (to know if it keeps the load?).

    Regards - MB

    0
    Comment actions Permalink
  • Toms

    hi,

     

    I have exactly the same problem!

    The Jaybird Freedom worked perfectly for 2 years then yesterday suddenly stopped working. The charge was 60%. Then suddenly it switched off and never turned on again. In the last weeks the volume down button was not working properly: instead of decreasing the volume it was skipping back the track. But prior to that I never had any issues. The battery has always been charged correctly and the headphones treated with great care. It is VERY awkward they stopped working EXACTLY now that the warranty has expired 30/09/19 was the last day for the 2 year warranty!

    0
    Comment actions Permalink
  • Deanna Stobbe

    This is exactly the same thing that is happening for mine. The same issue had for my old pair - still under warranty and were replaced but now the same thing is happening with new pair.

    0
    Comment actions Permalink

Please sign in to leave a comment.