I can't get my Jaybird Vista to work after accidentally exiting the app during a reboot from a firmware update.

Comments

11 comments

  • Official comment
    Tanner

    Hello everybody! 

    Thanks for reaching out to us on this! We're keen to isolate this issue and discover what is causing this for some folks and not for others. So that we may better understand what is causing this to happen, can you please reply back with the following information so that we can relay this information to our QA team for testing?: 

    • Device Model (Ex: iphone XR, or Galaxy Note 9) 
    • Device Operating System & Version (Ex: iOS 13.1.2)
    • Device Language Settings (Ex: English, French, Spanish, etc.)
    • Jaybird App Version (Ex: v3.6.2) - This can be found by clicking on headphones in the bottom right and then clicking on support from inside the application.
    • Approximate Date/Time when the users encountered the issues

    If you have any questions or concerns, don't hesitate to reach out.

    Cheers,

    Tanner // Jaybird Customer Experience

  • Katie Gasper

    My Jaybird Vista earbuds no longer work AT ALL after the firmware update.  They were purchased Aug 22, 2019, which puts them a few days over the 30 day warranty.  I've checked the website, but none of the Jaybird support pages work. I've messaged them on Facebook, awaiting instructions for support... 

    1
  • Travis Neal

    Same issue with mine.  After 20 minutes of the app saying rebooting please wait, the the ear buds never came back on and will no connect to any of my devices.  Removed them from the saved connected bluetooth items and still nothing.  Would be nice to have the support pages up and working on the website.

    1
  • Amy Wharewera

    Same thing happened to me also, purchased these yesterday and all worked well with the app and pairing but the app had an update. I did the update but it froze before finishing, I uninstalled app then reinstalled, now they won't pair on any device. Will be returning them tomorrow 🙄

    0
  • Jamie Smedley

    • OnePlus 6t
    • Android Version 9
    • Language - English
    • Jaybird app version 3.6.1 Build 412
    • Approximate date/ time - Thursday 29 September at 11am -12 am ( During the firmware update)

    0
  • Travis Neal

    Pixel 2XL

    Android 10

    English

    Jaybird App 3.6.1 Build 412

    Date of failed update that bricked buds was September 30th between 1pm and 2pm

    0
  • Katie Gasper

    Device : Google Pixel 2
    Operating System & Version: Android 10
    Language: English
    Jaybird App Version: 3.6.1 Build 412
    Approximate Date/Time: Sept 27-ish, around noon.

    0
  • Satyajit Patwardhan

    Just got my jaybird vista. Paired it to my phone and was working properly. Then downloaded the jaybird app. It said to update to a higher version. Then showed a message that it is rebooting my headphones. That message kept showing for long time.

    Now my vista is not visible to any bluetooth scan. Tried with my samsung phone, ipad, windows laptop. Did the soft reset, hard reset, individual headphone reset as per the troubleshooting on website. Charged it again for half hour. Still nothing. What next?

     

    • Device Model Samsung S6, iPad, Alienware m15 laptop
    • Device Operating System & Version Android7.0  iOS 12.3.1)
    • Device Language Settings English
    • Jaybird App Version  v 3.6.2 build 413 
    • Approximate Date/Time when the users encountered the issues 8th october, 1830 hrs, indian standard time
    0
  • Tanner

    All, 

    For clarity, the information that we're collecting is going to help us isolate the issue and hopefully prevent this from happening again in the future. However, if your buds aren't working now, it's not likely that they're going to be able to be recovered, and they will likely require a replacement.

    We'd be stoked to help you out! Please give our support team a call at 1.866.244.3399 between 7am & 5pm MT (USA) Mon-Fri (Excluding Holidays) and we'll get this situation all squared away with you!

    Cheers,

    Tanner // Jaybird Customer Experience

    0
  • Alex Bailey

    Also had the same issue. The firmware install failed half way through and now the buds won't connect.
    Tried soft reset and factory reset. No luck.
    Hard reset didnt work at all.

    Google pixel 3a XL
    Android 10
    English
    English
    App version : v3.6.2
    Firmware update attempted two hours before this post. 13:00 29 October Australian daylight savings time

    0
  • Zach Zappa

    Same issue here. Literally just got the earbuds today. I first connected them with Bluetooth and they worked great. I tried downloading the app and updating them, but the update was just stuck and wouldn't complete "finishing up." After trying to close the app and restart the process, they refuse to connect at all. I've tried every method of restarting the buds, restarting my phone and reinstalling the app and nothing.

    Pixel 2 XL
    Android 10
    Device Language: English
    App Version: v3.6.7
    Issue Occured on December 25, at about 9:00 AM

    This turned into a very annoying Christmas because of this :/

    0

Please sign in to leave a comment.