Jaybird X2 buttons seem to be acting on their own

Comments

2 comments

  • Official comment
    Bruce

    Hi Patrick,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    Let's try to do a factory reset, this should solve this issue you’re experiencing.

    1) Turn headphones off 
    2) Put headphones in pairing mode (hold middle button for 6-8 seconds until it says, "Searching for your Music Device")
    3) LED will flash red and green 
    4) Hold both volume buttons down 6-8 seconds, this will reset the headphones
    5) LED will flash orange 3 times 
    6) Delete Bluetooth profile from device 
    7) Put headphones back into pairing mode and connect them to your device. 

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Patrick Heard

    So, I tried this. Just like the multiple similar problems that I researched. I also guess that the next comment will be a contact number for the warranty dept that will in turn tell me that my product is out of warranty.
    So this is for anyone else that has a similar problem and comes across this.
    I loved my jaybirds, we had a good run, they lasted for more than the warranty. Which is what they were designed to do. I guess I expected a little more because I spent a little more on my jaybirds. Nothing I have found will remedy the problem. As I type this, I am hearing, power on, redial, power off, power on, headphones connected, power off...Today I will go buy new wireless headphones and try a different brand.

    1
    Comment actions Permalink

Please sign in to leave a comment.