Rubber peeling up on control buttons

Comments

7 comments

  • Official comment
    Bruce

    Hi James,

    Thank you for reaching out. Let me help you.

    I've sent you an email with details on how we will proceed with this one.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Brett Julius

    I discovered today that mine seems to have the same issue. I ordered mine on July 26 of 2019 and today, September 17, the rubber has began to lift up next to the + button.

    2
    Comment actions Permalink
  • Bruce

    Hi Brett,

    I appreciate you contacting us.

    Sorry to hear about what happened, I also sent you an email so please check that out.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    0
    Comment actions Permalink
  • Matthew Corey

    I am having the same issue with rubber peeling up on the buttons, whats the best way to proceed with getting this fixed?

    1
    Comment actions Permalink
  • nfmueller

    This has also happened to me.  @Support, can you send me an e-mail in order to resolve the issue as well?

    1
    Comment actions Permalink
  • Ron Shumate

    I have the same issue. I purchased my Jaybird Tara Pro earbuds at Best Buy on July 28, 2019 and they began peeling about 2 weeks ago. I am very careful with them, but I do sweat at work (which is why I chose them). I have the receipt from Best Buy that I can send to you. I really like them, but I can't trust a product that cost me around $175.00 and doesn't last 2 months before beginning to fall apart. I am very disappointed in this product. Not only are they falling apart, but they seem to have a mind of their own. I have set them up to never turn off since I hardly ever use them for 14 hours at a time, but they still disconnect from my phone and it always seems to be right when I am driving and I get a phone call. I have never had any previous earbuds do that before. It's almost like there is too much "technology" built into these devices and they can't handle the basic functions that people purchase them for. 

    Please send me an email as you have your other customers. It may be too late for a full refund, but I would like to at least get a replacement so that I can take advantage of them until they fall apart too. :(

    0
    Comment actions Permalink
  • Andrew Gay

    I would be interested in hearing from Jaybird Bruce what they have done in a manufacturing sense about this issue.

    I have just picked up my third pair after the first two did the same thing - Both pairs lasted about two months, It doesn't seem to affect the way they work but I'd imagine waterproofing is compromised when the rubber lifts.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.