Audio Latency Issue with Jaybird Vista?

Comments

26 comments

  • WuMyster

    I have the same issue and am using them with an iPhone XS. 

    Reviewers all state there is no latency issues but mine are clear. Not sure if yours and mine are faulty or if reviewers are just unable to see a difference.

    1
  • Christian Rustøen

    I'm very surprised to hear that you experience audio latency problems with the Vista pair. Like WuMyster Ive also read a lot of reviews either on youtube or for example on the wired website and they all state and say they have tried the earbuds without any latency issues. This is so annoying that you experienced this because that means that we cant trust even the review on wired which should be a pretty reliable source... and most youtubers will tell the truth in the review.. so im pretty surprised.

    Would love to hear other peoples experiences to see if its a problems with some and not with others.

    Edit: DasDoomGuy and WuMyster: Do you have the same problems if you are using them with a laptop ? It would be interesting to isolate the problem to specific devices. Would also like to know how big the latency issues are. Are they almost not noticeable or significant ?

    1
  • Moritz Post

    I am having similar latency issues. Video is noticeably laggy on my pixel 2xl as well am on a iPad pro 10.5. My firmware is 1.10 I think. Could anybody resolve the problems?

    1
  • Stian89

    Same here! Videos on a Huawei P30 Pro is clearly lagging audiowise.

    0
  • glenn gauci grech

    Thank god i held out on these so far. Im still interested but waiting to see of this gets resolved first .. was waiting on user opinions.

    0
  • Dave6992

    Latency here as well, although not so much with Netflix, but definitely YT on my ipad. On my second pair of Vista’s and both have been identical.

    As for the reviews stating no latency, well they were all up-loaded before the official release. Make of that what you want, I know what I think.  

    0
  • WuMyster

    @Christian Rustøen

    Interestingly on my W10 PC the latency is still noticeable but not as bad as on my iPhone. Will check on my Macbook Pro later. 

    0
  • Dave6992

    I have read that iOS devices do have an issue with the Vistas and that latency can be expected, but I can see that not all of us have iOS devices.

    0
  • DasDoomGuy

    So today I have been watching a lot of youtube videos for while and it seems like after you are using these for a bit, the latency gets better and is greatly reduced. Has anyone else noticed this?

    0
  • WuMyster

    @DasDoomGuy

    Definitely not for me. I've been using them all day today and the latency at 8am was the same at 5pm.

    1
  • Christian Rustøen

    Well this is strange. I heard with another person who has these earphones and they dont experience much lag. They do experience a slight lag, but not enough to be noticeable unless you really pay attention to lag.

    Usually the people who comment on this are people who are watching youtube on an apple phone device and they report almost no latency when using it with netflix or HBO - or similar.

    I did contact Jaybird Support about this and they said that you need to troubleshoot if the latency is coming from the connection or from the video. You need to re-connect the device and try it with multiple devices to isolate the issue. Kind of obvious, but you need to raise a ticket with them if you want try to get a fix.

    According to someone I spoke to you can take the following test:

    https://www.youtube.com/watch?v=ucZl6vQ_8Uo

    that doesnt solve the issue but it should give an idea about how bad the lag actually is. Try it using multiple bluetooth devices espcially your laptops as the phones might be an issue here - although several people has reported no noticeable lag here as well, but thats mostly on android devices. Almost everyone ive seen has reported lag on their phone and almost noone has reported any testing on a computer.

    @WuMyster would be interesting to see if you could test this on your macbook.

    @Dave6992 why should the products they use be any different in the reviews just because its a pre-launch ? I wouldnt imagine that they change the product after having sent the pre-release

    0
  • Dave6992

    Well who knows what FW they had when they did the tests. I know with both my sets i upgraded the FW straight away. Could be different to what the reviewers were using.

    This was the case when DJI launched the Osmo Pocket. All the previews had a couple of features that were taken out of the final release. This caused a lot of confusion and disappointment.

    The other possibility is they were keeping JB sweet, so wouldn't publicly say if there were issues. I tend ot find reviews where they have been given the items cant always be trusted 100%. Ive never seen a pre review that has been negative. 

    0
  • Christian Rustøen

    Thats true, they probably had a different FW, but i do find it strange that they would be able to ruin the latency with a few firmware updates before the real launch.

    Reviews or not ..ive spoken to people that has bough this after the release and while they do experience a slight latency at times they dont report any significant latency issues at all.

    This was the response i got from a person who has these and bough them after the launch:

    "I got these a couple of days ago. They sound great, have a secure tight fit and are super convenient. What I found is that the jaybird app is super important. I didn't think I would need it to mess around with the EQ but it makes a HUGE difference. I like my music to have a lot of bass and the app can do just that. The sound is completely customizable to your liking. If you're wondering how they work with YouTube videos in terms of lagging, they work absolutely perfect and there's no lag. I watched this video (along with many other videos on YouTube since I got them) and there's no lag. When talking on the phone, you have to talk normally and if anything, a LITTLE bit louder so the other person can hear you and the person on the other line sounds clear and loud. If any of you have questions about them, feel free to just reply to this!

    "I am watching on my iPhone 6s. If you take the time to try to notice the delay, you'll find that there's a SLIGHT delay. However, the amount of lag is so small that watching videos is enjoyable unless you are trying to look for it. I hope that makes sense. What I did was search a video on YouTube that measures the audio/video lag and it seems like it was posted by a twitch channel. If you use that as a reference, watching that video with my earbuds, the noise will be heard a little after the zero mark. It is a very small delay and should be nothing to worry about. I mainly bought these to listen to music and watch videos on YouTube (which youtube is what I mainly use it for). I was worried about there being a delay but there is little to no lag so you should be fine (:"

    So there certainly are people who dont experience much of this if at all. I also sent requests to a couple reviews to re-review this product but i havent heard back.

    I've been to one electronics store to ask about what they though but they havent received them yet in stock. There is another electronics store im going to visit to see if they have tested these.

    Did you do anything to try to isolate this issue Dave ? Try it out with a few different devices witht the same applications on each. If the problem is equally notieable it could very well be the connection or if it works good on netflix it probably the video. It sucks either way but it better to do something constructive and find out where and what causes the problem.

    0
  • Stian89

    On my Windows 10 laptop there is small, barely noticable, audio latency on YouTube, etc.
    When I am on my Huawei P30 Pro, there is a very noticable latency. I have tried Youtube and Plex on the phone.

    0
  • Adam W

    Hi everyone, 

    Thanks for the feedback on this thread. 

    Can you please confirm if there is any audio lag once updated to the latest firmware for Jaybird Vista v1.1.3?

    Thanks in advance. All this feedback does go to the product team.

     

    Adam

    Jaybird Customer Experience

    0
  • Moritz Post

    While performing the upgrade process to 1.1.3, everything looked good. At the end the the process said "restarting" but it never completed. I tried warmstarting them, tried a factory reset and even the 20 long press to hard reset but none of that helped. The vistas won't turn back on.

    I followed all the steps outlined here: https://www.jaybirdsport.com/en-us/jaybird-support/jaybird-vista/faq/troubleshooting/how-do-i-reset-my-earbuds.html

    Is there anything else i should try?

    0
  • Adam W

    Hi Moritz,

    Thank you for the feedback. 

    I have created a ticket for you and a team member will be in touch with the next steps.

     

    Adam 

    Jaybird Customer Experience

    0
  • JayBirdStoodByTheirWarrantyInTheEnd

    They really are a poor quality product. Check out their reviews on Trust Pilot. They refuse to honor their product warranty and outright lie to their customers.

    Good luck trying to claim on your warranty.

    0
  • Dwight Jackson

    I have the latest update. I love these Vistas. My only problem with them is that I watch a lot of videos on my phone. Mainly on Youtube. There’s a noticeable lag latency. Driving me nuts! Can you guys @jaybirdsupport fix this issue?

    0
  • Adam W

    Hi Dwight, 

    Great to hear you love your Vista!

    Your feedback has been passed onto the development team. Please watch this space!

     

    As always, our team is always ready to help if you need.

     

    Adam

    Jaybird Customer Experience

    0
  • Dan

    I'm experiencing about 300-350 ms of latency with these connected to my phone (Pixel 2 XL). Measured using a YouTube video and again with a downloaded metronome app. I also tested some cheap Bluetooth headphones for comparison and I see something like 50 ms of latency on each test, so it's definitely something specific to these headphones and not an issue with the video or the app. Oddly, I see very little latency with these headphones while they're connected to my laptop, so it's something to do with how the headphones are interacting with the phone. Again though, I do NOT see this latency with other Bluetooth headphones though, so something is definitely wrong with the Vistas. I've seen others say their latency is not distracting, but 300ms is untenable to me, so I'm curious how my experience compares with others'. I'm sad to have to send these back, but it doesn't look like I have a choice. 

    1
  • Howard1330

    Still have latency issues with my pixel 2xl. It is definitely noticeably.

    1
  • Christian Rustøen

    I also have the latency issues. Sometimes there is a slight delay and sometimes there are a very noticeable delay. There is no doubt that there are delays though, although usually its not sometime that bothers me much, but sometimes its unwatchable when watching movies, but that is not that often, but there are always some kind of delays.

    1
  • Fernando Nazario Sousa

    Hello everyone. Yesterday I tweeted to @jaybirdsport about this lag when watching videos.

     

    You keep experiencing this audio lag?

    0
  • WuMyster

    Fernando Nazario Sousa

     

    I had the Vistas from launch day and had a fair amount of lag but I can confirm they've fixed it now. Both of my pairs have no lag at all. 

    0
  • Johnny Nguyen

    Did they fix it for the Runs too?

    0

Please sign in to leave a comment.