Tarah Pro Red Light stays on draining battery - right out of box and nothing from support so far

Comments

8 comments

  • Official comment
    Bruce

    Hi Rick,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    I've sent you an email with details on how we will proceed with this one.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • thomas andersen

    hi there. was this solved? I have the same problem. LED is always red - regardless of all resets. the kit worked for 6 monthsbut now battery drains in no time even when not used. please submit the solution. thx

    0
    Comment actions Permalink
  • Khairul anwar Abu mansor

    I also have the same problem

    0
    Comment actions Permalink
  • Simon Schubert

    Same problem, very frustrating, straight out of the box and wasn't working at all, constant red light and unresponsive

    0
    Comment actions Permalink
  • Fabiano Ferreira

    The same problem here, i tried to update the firmware, factory reset but did no work, its draining the battery when not in use, last friday it was with 93% so i just did not use it to test in the weekend and today is with 74%.

    Just returning it back to the store, very frustrating, did no find any solution here and i have just 3 more days to return it.

    Jaybird, ok to have problem but a lot of people here with this problem and no answers or solution? reset does not work at for this problem. You should say something about this problem to all consumers and not just send me to reset or to send an e-mail. 

    0
    Comment actions Permalink
  • Rick Dinsmore

    Their only solution has been to replace the earbuds.  It has taken 3 replacements to get a pair that worked as they said.  I have not posted up to this point waiting to see if they last (a little over 2 months).  Just started experiencing that they would not fully charge and white light does not flash when connected.  Have done all the resets.  Now going to run them until the battery is depleted and then try to recharge.  Will update all if this fixes the issue.

    0
    Comment actions Permalink
  • Fabiano Ferreira

    Thank Rick for the update, i asked now the refund and i don t think i will try another one, i will have to look for jabra or another brand... 

    0
    Comment actions Permalink
  • hera oktaviani

    Hi all, just bought it for 1 day, and the red light issue is the same, wont off. Been tried all the suggested ways to reset, to press the button, to pin the 2 buds for 15 minutes via apps, all are failed. Sad since this is my birthday gift for myself. @bruce, please help. I bought this in Singapore, while I live in Indonesia. How can you help me?

    0
    Comment actions Permalink

Please sign in to leave a comment.