Left earbud stopped working

Comments

4 comments

  • Official comment
    Bruce

    Hi Anthony and Mauricio,

    This definitely shouldn't be happening but I appreciate you reaching out.

    Please try these suggestions that can help to resolve the issue of your headset:

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Mauricio Soto

    I have the same problem. My X4 stopped to work after some weeks and the reset doesn’t work

    1
    Comment actions Permalink
  • Anthony Bennett

    Hello Bruce, none of these have worked. The headphones turn on, and the right one works fine, its just the left one doesn't work at all. 

    1
    Comment actions Permalink
  • Larry Shipp

    I'm having the exact issue with x3.  Right works fine but left not working.

    Larry

    1
    Comment actions Permalink

Please sign in to leave a comment.