Device won’t turn on

Comments

7 comments

  • Official comment
    Bruce

    Hi Marlus,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    I've sent you an email with details on how we will proceed with this one.

    @Dennis and @Benjamin, please let me know if the suggested troubleshooting worked for you. If not, please me know.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Benjamin D

    I’m having this same exact issue. Is there anything that can be done to troubleshoot/resolve?

    0
    Comment actions Permalink
  • Marlus Lago

    Hi Benjamin D. Well, I tried like they said, to charge it from the lap top, press and hold the power button for at least 10 sec, pressed all of them simultaneously, pressed them individually for various seconds and nothing. My device is dead! And almost 2 months old and not using it frequently. I noticed it happens a lot, several people complained about it, now I’m waiting return from the company. I have another one (Bose) running perfectly for almost a year now. And to think I was in doubt at time of buying and chose this Jaybird...

    0
    Comment actions Permalink
  • Dennis Sand Eskesen

    Exact same issue : 2 runs - 4 days old and completely dead….

    0
    Comment actions Permalink
  • Shelby Powell

    I had a pair of X3s for less than 6months with this same issue. Spoke with Jaybird support and non of the trouble shooting solutions resolved the problem. Jaybird sent me a pair of X4s and now I’m having the very same problem after only 3 months. What’s the deal Jaybird??

    0
    Comment actions Permalink
  • Chris Portella

    Hey Jaybird or Community, 

     

    Dealing with the same issue. Same frustrations. Can someone share the troubleshooting instructions? 

    Thanks,

    CP

    0
    Comment actions Permalink
  • Thomas Wyler

    Hi Bruce and Jaybird Support

    i have the exact same issue with my x4 (and with x3 before that).

    i was on a bike ride 2 days ago and they suddenly turned off for no reason.

    now they were charging for 2 days and the green light is on but when i take them from the charger i can't turn them on again.

    could you please send me a solution what i have to do?

    thanks 

    T

    0
    Comment actions Permalink

Please sign in to leave a comment.