Jaybird x3 solid red light

Comments

3 comments

  • Official comment
    Bruce

    Hello Stan,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    Here is a list of steps for the Factory Reset that will help resolve the issue:

    1.Make sure your buds are powered off.
    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.
    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • John Montgomery

    Have the same constant red light issue. I updated to latest software and I followed the Factory Reset steps. I saw the LED flash rapidly and heard a double tone. It did not fix the issue. Still have a constant red light. Please advise.

    0
    Comment actions Permalink
  • Bruce

    Hello John,

    Thank you for providing an update.

    I've sent you an email with details on how we will proceed with this one.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    0
    Comment actions Permalink

Please sign in to leave a comment.