Headphones won’t turn on; charger responds as fully charged

Comments

13 comments

  • Official comment
    Bruce

    Hello Jehan and MusiChuck2,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    Please try these suggestions that can help to resolve the issue of your headset:

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • MusiChuck2

    I am having the exact same issue. I can't even attempt a factory reset because it won't respond. Indicator LED shows that they are fully charged. This is my first problem with the X4. These are less than a year old, too.

    0
    Comment actions Permalink
  • Jehan Saga

    Hi @Bruce. This does not resolve the fact that the headphones won't work. They do not turn on and changing the charging source is not charging the headphones which appear to be fully charged,

    0
    Comment actions Permalink
  • MusiChuck2

    @Bruce The issue isn't that the X4s won't charge, they LED indicates that they are fully charged. They simply won't turn on. The buttons are not responsive.

    0
    Comment actions Permalink
  • Bianco Bianchi

    Same here, I used my X4s yesterday, left them 80% charged, but today they are dead and totally unresponsive. Had the same issue with the X3s (refunded by Amazon). Really disappointing.

    0
    Comment actions Permalink
  • James Bonk

    I have the same issue with my X4.  The power button is not responding.  I see some traffic about the foil below the button not making contact but I sure do not want to take it apart. 

    0
    Comment actions Permalink
  • Danny KONE

    Hello, I have exactly the same issue with my X4 - 6 months old . I have contacted the support that promise a response within 48h but I have no hope as it seems a commun issue and obvisously jaybird has no solution. disappointed ! 

    0
    Comment actions Permalink
  • Thomas Weigle

    Having the exact same problem as the others... Jaybird, when can we expect a response? These are too expensive to not have this resolved.

    0
    Comment actions Permalink
  • Simon Berry

    Exactly the same issue - Bought this in May and I had a solid yellow LED light in when charging in the cradle now they indicate green and fully charged but they will now not turn on so I don't have access to any of the reset functions.

    0
    Comment actions Permalink
  • Jerome Garcin

    Exact same issue here. Green light says fully charged, headphones not turning in. Tried the reset steps but no changing. Also tried to apply your suggestions but no changing. We’d need a efficacious solution or replacement (a few months old headset, never used in any other situation than for running). Thanks

    0
    Comment actions Permalink
  • Brandon Stell

    I have the same issue my X4s that are 5 months old.

    0
    Comment actions Permalink
  • Demian Vincenty

    Add me to the list - green light says charged but the power button is unresponsive. Any solutions? Thx @Jaybird_Bruce

    0
    Comment actions Permalink
  • Brandon Stell

    Note that, as was pointed out above, the official response above from Bruce does not solve the issue.

    0
    Comment actions Permalink

Please sign in to leave a comment.