Charging clip won't charge buds

Comments

5 comments

  • Official comment
    Bruce

    Hello Dylan and Kerri,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    Have you tried to charge both the clip and the buds at the same time?

    Please also try these suggestions that can help to resolve the issue of your headset:

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2.5 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Kerri Kincaid

    Same here! It’s like all of a sudden the connection between the charging clip and the headphones doesn’t connect....

    0
    Comment actions Permalink
  • Dylan S.

    Yes I have, I have tried everything and can't use my buds.

    0
    Comment actions Permalink
  • Panos Papapaschalis

    Same here. After a bit more than a year of moderate use, the connection between the clip and the buds no longer words. What a waste...

    0
    Comment actions Permalink
  • Tørris Toftdahl

    Mine dosent work either, tried with different charge clips, still dosent work, this is the fourth or fifth pair of jaybird freedoms and this has been a problem through almost all of them

    0
    Comment actions Permalink

Please sign in to leave a comment.