Freedom F5 not charging/turning on.

Comments

2 comments

  • Official comment
    Bruce

    Hi Adam,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    Please try these suggestions that can help to resolve the issue of your headset:

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2.5 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Adam Hirko

    I have tried a number of suggestions listed here as well as trying to reset them. I've even attempted to not use them for several days, hoping whatever the issue was would sort itself out. Today I tried to turn on/charge for the first time in about two weeks. They briefly had a flashing light, that was new, but it didn't last. It stopped flashing and returned to not charging/turning on/doing anything.

    I am very dissatisfied with these headphones. They were great while they worked, but then all of a sudden stopped for no apparent reason.

    0
    Comment actions Permalink

Please sign in to leave a comment.