Charging case will not enter pairing mode.



  • Official comment
    Bruce B.

    Hi Jon and Benkleinil,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    I included a link for soft and hard reset instructions here:

    Feel free to reach back to us by replying to this post or contacting our other support channels at

    Warm Regards,
    Jaybird Customer Experience

  • Benkleinil

    Same here, pressing the button just makes the LED go off. No way to pair these?

  • DavidF

    I had a similarly weird experience but came to the realization to you may  need to (must? seemingly must) place both your Vistas into the charging cradle in order to pair with the cradle. Possibly you guys have already tried this, but if not, have a try with that (somewhat non-intuitive) approach. 

  • Scott King

    I just received my new Vista earbuds today. I'm having almost the identical problem except no pairing at all. No matter how long I hold down the case button it won't enter pairing mode. Factory reset doesn't work either. Case fully charged to a solid white for 2 hours. I'm so disappointed, I guess I'll have to return this to Best Buy and buy a different product.  

  • Er MH

    Yes, this happened to me twice - the first time after 1 month of use.

    The 2nd time which is now, after 3-4 months of use after getting a new replacement set from the local distributor.

    The charging case will not enter into the pairing mode as i tried to do a hard reset. The left earbud persistently gives a buzzy noise. It is also charged less than the right earbud.

    Looks like this issue is a systemic bug for Jaybird Vista, judging by the similar cases reported in this website.

    I'm terribly disappointed and disgusted by the FRAGILITY of this product. Twice in a row that the case go into pairing mode.

    The experience is totally different from the fave reviews from all endorsement from Youtubers.

    I'm so angry right now as i have to seek restitution from the local distributor for the 2nd time, wasting my time.

    I'm uninstalling the Jaybird app from the phone as I will not EVER consider Jaybird AGAIN.

  • frank rotella

    I’m having the same issue now!! Please help Jaybird!!!

  • Matt Waller

    Same here!!


  • Justin Brown

    Same with me. Brand new set out of the box. Fully charged. Pressing and golding the case button to enter pairing mode doesn't do anything. No flashing led, no new Bluetooth device discovered on my phone. Any ideas here?

  • Matt Waller

    i sent them back and got a new pair.  New pair worked fine first time.  Amazon sorted very quickly!

  • Justin Brown

    Cheers... Back they go!

  • elad dimant

    I have the same problem. They worked for only one time.

  • Jonathan Lim

    Hello Bruce,

    you've have been really helpful in the past. This Jaybird Vista have been working fine for a while. but I do not recall any recent firmware updates, and suddenly I am unable to pair. I have followed your instructions to a tee in soft resetting and completely factory resetting it but I face the problem the rest of the people face above too. long pressing the button does not put the case into a flashing white which leaves us unable to pair. Could you please help us out here?

    would really appreciate it.


Please sign in to leave a comment.