My Jaybird XT keeps losing signal continously

Comments

5 comments

  • Official comment
    Bruce

    Hi Varun/Jeffrey,

    Thank you for reaching out. This definitely shouldn't be happening, let me help you.

    Please observe the buds to further isolate the issue, you can connect the buds to a different device or a device with a different OS. Resets are also recommended, I included both methods:

    To soft reset your right earbud:

    -Place your right earbud into the charge case and close the lid.
    -Open the charge case and remove your earbud.

    To hard reset your right earbud:

    -Turn off your right earbud by pressing the right multifunction button for 3 seconds.
    -With your right earbud off, press and hold the right multifunction button for 6 seconds until the LED flashes green.
    -Double press the right multifunction button. The LED will flash orange and the earbud will turn off. Your earbud has now been reset.
    -When you hard reset your earbuds, you will lose any saved presets and any saved devices on the paired list. You’ll need to forget Jaybird RUN in your phone's Bluetooth device list, repair your earbuds to your Bluetooth device, See How do I pair my Jaybird RUN earbuds? and reselect your favorite preset from the Jaybird app.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Jeffrey Wong

    same issue. Write in but no response from support.

    0
    Comment actions Permalink
  • Jeffrey Wong

    Thanks Bruce, i received your email telling me to do a hard reset. I have replied and would like to share the details here with all user. Despite doing the hard reset i am still having the same issue. The earbud only works with spotify and "music" on iphone XR. Once i switch app to youtube or facebook, both earphone or left ear bud goes mute.
    Also, when i am on spotify or music, both ear bud will go out of sync for few seconds (take turn to go mute for about half seconds).

    Its really irritating to encounter these issue. Seems like the quality assurance is not doing a proper job or Jaybird just want profit and quickly push out poor quality product.

    I want to get a refund!

    0
    Comment actions Permalink
  • Varun Chakravarty
    Hi Bruce, 
     
    I have done all the following things that you have mentioned. It works fine for some time but after a couple of weeks - the same disconnect, break, audio loss and lag connectivity keep happening. 
     
    After using Jaybirds X3, I was totally sold on Jaybirds and even though the reviews were negative about the XT, I still went ahead with it. To my dismay, they had way more issues than just the lag in the video. 
     
    I'm stuck with a SGD $300 pair earbuds and keep borrowing my girlfriend's apple airpods. 
     
    Hope you understand. They're not a cheap pair in the market but I could have gotten better brands in the buck I shelled out. 
     
    Best Regards,
    Varun 
    0
    Comment actions Permalink
  • Dennys Santos Sobrinho

    This same issue is occurring on my Galaxy S9 Android PIE 9 and RUM XT, even after some Jaybird app updates (latest 3.6.0)

    Apparently the JayBird APP is closed by Android intermittently.

    0
    Comment actions Permalink

Please sign in to leave a comment.