Jaybird Tarah Pro Not charging

Comments

12 comments

  • Official comment
    Bruce

    Hello WatchFace Man,

    Thank you for reaching out with regard to your concern. I will be happy to help you.

    Please try these suggestions that can help to resolve the issue of your headset:

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • WatchFace Man

    Hello I have tried all the methods that you have listed.
    I tried charging using a laptop usb port.
    I tried using different usb adapter.
    I tried using a power bank.

    In all the cases Jaybird didn't charged either the charger is defective or the device itself. Kindly send me replacement unit. Bought them just 2 days back and this is happening now. This was the experience I didn't expected.

    1
    Comment actions Permalink
  • Bruce

    Hi WatchFace Man,

    Thank you for reaching out.

    I have sent you an email with regard to this case.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    0
    Comment actions Permalink
  • Robin Barkman

    I have the exact same problem and have tried all of the above.

    "Battery low, please charge", and when I out them to charge in computer USB or 1AMP socket, the light is pulsing for about 5-15 seconds before it turns off completely.

    What to do?

     

    Robin

    1
    Comment actions Permalink
  • David Ozolin

    I’m having the same issue. I put my headphones on the charging cradle and the LED turns off in about 15 seconds and stops charging. The only way I can charge this thing is to keep taking it on an off of the charger every 15 seconds. I have taken all of the steps listed by support above.

    0
    Comment actions Permalink
  • WatchFace Man

    Recently the quality of Jaybird products has really degraded. I originally used the Jaybird X3 they were awesome in build quality performance and overall usage. But with the Tarah pros and Jaybird X4 I'm really disappointed from Jaybird.

    0
    Comment actions Permalink
  • Mike Hart

    Did anyone find a solution to this? I just got a pair of these last week and have been unable to use them or charge them and I have gotten no response for Jaybird...

    0
    Comment actions Permalink
  • Robin Barkman

    Mike, it seems this is a known problem - Logitech confirmed to me in an email. Not sure why they are not publicly confirming in answers on this forum? I suggest you contact the reseller to get a new pair. Otherwise you should send an email to Logitech support. I was very pleased with their help.

    Another options is to try charging them with another charging cable. Odds are high you have another one but try if you are able...

    Robin

    0
    Comment actions Permalink
  • David Ozolin

    Mike,

    Not long after my post there was a software update and since that time my headphones have charged with no problems. Hopefully your situation can be fixed.

    Dave

    0
    Comment actions Permalink
  • Thomas Godsell

    I've had the same issue, headphones work great, just they wont charge and now down to 8% so can't install the update that another user said solved his issue. Does someone have the Logitech email please? they didnt get back to my request through the portal

    0
    Comment actions Permalink
  • Marcus Reinders

    I have the exact same issue as the posts above have mentioned. I will try taking them back to where I bought them and see if they will replace.

    0
    Comment actions Permalink
  • Michael OSullivan

    Same problem here. Really disappointing. Agree with the prior comments re the quality.

     

    I had X3s that were great. My X4s were replaced twice inside 12 months before I lost them.

     

    Now the new (supposed top of the line) Tarah Pro won't even turn on. 

    0
    Comment actions Permalink

Please sign in to leave a comment.