X3 right bud noisy

Comments

3 comments

  • Official comment
    Bruce

    Hi Gurru,

    I am sorry to hear that your Jaybird X3's right bud is noisy. This is not the quality we're expecting from our product.

    Please check your buds are clean and free of debris.

    Here is a list of steps for the Factory Reset that will help resolve the issue:

    1.Make sure your buds are powered off.
    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.
    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

    You can further isolate the issue by testing using a different device or a device with a different OS and checking the voice prompts if it plays on both sides.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    Comment actions Permalink
  • Gurru Shyammala

    Not working still. Can you replace my device?.. I am willing to upgrade to better model Tahoe pro by paying the difference in cost.

    0
    Comment actions Permalink
  • Bruce

    Hi Gurru,

    Thank you for reaching out.

    I have sent you an email with regard to this case.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    0
    Comment actions Permalink

Please sign in to leave a comment.