Jaybird Run Charging Case Stopped Working

Comments

5 comments

  • Logi_Bruce

    Hi Mike St. George,

    I am sorry to hear that your Jaybird Run charging case stopped charging. This is not the quality we're expecting from our product.

    Kindly try using a different power source/charger and/or a different USB cable. A pulsing green LED on each side means it is charging, solid green light when fully charged. It is recommended to use 5V/500mA-1A charger for 2 hours only.

    It would also help to ensure that the lid of the charging case is securely closed and the charger ports and prongs align accordingly and are free from debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    0
    Comment actions Permalink
  • Ashleigh Chislett

    Hey, did your issue ever get resolved as mine is doing exactly the same thing?

    0
    Comment actions Permalink
  • wei cia

    I am having same issue like Mike St. George. Also did try change to use other charge and cable. There is totally no light when putting in ear buds in charging case. When just purely charging the case, the LED will blinking like green green then red. It seems like something wrong with charging case

    0
    Comment actions Permalink
  • Ofek Levi

    Hi, did jaybird helped your problem?

    im having the same issue..

    0
    Comment actions Permalink
  • wei cia

    @Ofek Levi: I went back to the shop where I bought and item still under warranty, so they take it back for jaybird to investigate, and replace a new one

    1
    Comment actions Permalink

Please sign in to leave a comment.