Red light won’t go off

Comments

3 comments

  • Logi_Bruce

    Hi Jeffpop,

     

    I am sorry to hear that your Jaybird X3's red LED won't turn off. This is not the quality we're expecting from our product.

     

    Here is a list of steps for the Factory Reset that will help resolve the issue:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.

    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Jeffpop

    Unfortunately this didn’t work. I have read other posts and they also said this doesn’t work. It appears the X3 has a design flaw. Any other possible solutions?

    0
    Comment actions Permalink
  • Bruno18

    My X3’s does the exact same thing and the above answer does not resolve the issue. The light stays on. For me this issue has happened twice. It happens when I charge it on my work computer. My only resolution is time. What is strange is when charging them all day on the work computer, the light never shows a full charge green light. It just glows red/orange even after you remove it from the charge cord. The unit works fine except for the light never turns off until the battery eventually dies.

    0
    Comment actions Permalink

Please sign in to leave a comment.