Hi, I have bought the Jaybirds x3 in december 17'. Three pairs of my ear buds broke completely. And now my cable broke, so I can't hear properly... Is there anything you can do? thanks for reply yours sincerely, Jan

Comments

2 comments

  • janbozic23

    Hi Ckim90,

     

    I am sorry to hear that your Jaybird X3 does not hold a charge. This is not the quality we're expecting from our product.

     

    I've sent you an email with details on how we will proceed with this one.

     

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

     

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
  • janbozic23

    Hi shaolin95,

     

    I am sorry to hear that your Jaybird X3's right bud stopped working. This is not the quality we're expecting from our product.

     

    Please check your buds are clean and free of debris.

     

    Here is a list of steps for the Factory Reset that will help resolve the issue:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.

    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

     

    You can further isolate the issue by testing using a different device or a device with a different OS and checking the voice prompts if it plays on both sides.

     

    As for warranty, the X3 has a one-year limited warranty. Please refer to the information on the box/packaging as well as your user guide/manual.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0

Please sign in to leave a comment.