My X2 is charged but will not power on.

Comments

7 comments

  • Bruce

    Hi Akfisherman,

     

    I am sorry to hear that your Jaybird X2 won't turn on. This is not the behavior and performance expected from the product.

     

    Please try these suggestions that can help to resolve the issue of your headset:

     

    - Computers are the best and safest method, as is anything 1 AMP or less.

    - Try a different power source/charger

    - Car chargers produce a much greater power supply and should be avoided.

    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2 hours,

    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.

    - Avoid charging your headphones after exposure to sweat.

    - Make sure charging port/cradle is clear of any debris.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Jerry Pasol
    Bruce The light on power when plugged is green; however, still not powering on.
    1
    Comment actions Permalink
  • Nicole Hughes

    following this thread - I'm having the exact same problem

    1
    Comment actions Permalink
  • Jessica Kaster

    Having the exact same problem - the solution already provided clearly will not solve the problem - the headphones are completely charged (as indicated by the green light) but will not turn on. Please advise on how to get the headphones to turn on.

    1
    Comment actions Permalink
  • Darin Cepeda

    Same issue here, and it just started happening.

     

    My pair will take a charge, going from red LED to green LED, but won't turn on.  Holding the power button down does nothing.  Won't turn on or do anything.  If I let them sit for a period of time (hours, a day, etc.), I'll plug them in again and the red LED will come on, showing they are charging again (which is expected given some small amount of battery drain).

    1
    Comment actions Permalink
  • Emily Keegan

    Me too. Headphones stopped working 1 year from purchase, and now battery will appear as if its charging, but wont turn on.

    Full description below - 

    Red light stayed on constantly so drained battery in a couple of hours. Resetting it (8 second hold then double tap did nothing). Now they’re completely dead even after 20+ hrs of charging. Red then amber light does show when charging but now is dead when not plugged in to the wall. Doesn’t turn on even when plugged in. 

    Can anybody help? 

    1
    Comment actions Permalink
  • Patrick Pierre-Victor

    I'm having the same issue. I've tried charging my headphones on a computer, portable charger, and wall outlet. My Jaybird X2 headphones will switch from red LED to green LED indicating that they are fully charged, but will not power on. There are several comments in this thread as well as several others over the years indicating the same issue but the support team has not resolved our problems. I've never charged my headphones longer than 2 hours and never charged them when they are wet from rain or sweat. I've had them for 2+ years now and it's unfortunate that I will not purchase another set from Jaybird due to the lack of support and poor quality of the product. 

    See other threads below with no resolution:

    https://support.jaybirdsport.com/hc/en-us/community/posts/360032908054-My-X2-won-t-turn-on

    https://support.jaybirdsport.com/hc/en-us/community/posts/360032952974-My-Jaybird-X2-doesn-t-turn-on-anymore-It-was-fully-charged-and-the-light-is-green-when-plugged-with-charger-What-should-I-do-or-try

    Best,

    Patrick

    1
    Comment actions Permalink

Please sign in to leave a comment.