Battery Low announcement despite fully charged

Comments

6 comments

  • Bruce

    Hi eav1ck,

     

    I am sorry to hear that your Jaybird Tarah keep announcing that the battery is low. This is not the quality we're expecting from our product.

     

    Please try the following to resolve the issue of your headset: 

     

    Before starting this process please “FORGET” or “REMOVE” your Tarah device in your Bluetooth list of discovered devices in your phone or music device.

     

    1. Put your earbuds in to pairing mode. Press and hold the Middle Button until the earbuds turn off. Then press and hold the Middle Button for 5 seconds until the white LED starts blinking.

    2. While the white LED is blinking press the Middle Button twice.

    3. The red LED illuminates briefly, and then the white LED starts blinking again.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • eav1ck

    I followed all the steps (I noticed the LED blinking pattern changed as described by you), but it didn't help. At the end, it start complaining "Battery Low" again when I start it.

     

    Is there any process which I can full reset it?

    0
    Comment actions Permalink
  • Lucio Lapeña

    The same is happening with my Tarah Pro just bought 3 weeks ago. Didn´t expect this kind of problems in a brand new headphone of 160 dollars.

     

    Followed all the steps to reset them and  the "Battery Low" issue happens everytime I start ir. 

    0
    Comment actions Permalink
  • Elizabeth Taylor

    I have been having the same issue. I’ve had my Jaybird tarah for about 4 months. I tried the above steps and it did not fix the problem. Please advise regarding next steps.

    0
    Comment actions Permalink
  • Drew

    Same issue started on my Tarah, about 2 weeks ago.  Did hard reset, and no change, going to attempt to run the battery down and charge, to see if that makes a difference.

    0
    Comment actions Permalink
  • Logan Talle

    Try cleaning the buds.

    0
    Comment actions Permalink

Please sign in to leave a comment.