The right ear of my Jaybird X4 is not working, I've looked through every possible way and it is not working

Comments

6 comments

  • Bruce

    Hi clarasc,

     

    I am sorry to hear that your Jaybird X4's right bud is not working. This is not the quality we're expecting from our product.

     

    Here is a list of steps for the Factory Reset:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.

    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

     

    You can further isolate the issue by testing using a different device or a device with a different OS and checking the voice prompts if it plays on both sides.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • clarasc

    Hi,

     

    I've tried all of these at least 10 times and the quality of this product is not worth the price. Although Jaybird is a brand renowned for it's reliability, the X4s simply does not align with that notion. Is there anything else you could provide with me to fix this problem other than giving me "expertise" information I could just look up on my own?

     

    Thanks

    0
    Comment actions Permalink
  • BMinor

    I bought a pair of the X3 that failed due to the charging issue. They replaced them two more times and then the third time I begged them to send the x4 instead as all of these sets are basically still new and don't work and now the X4 two months old and the right earbud doesn't work! This manufacturer is so unreliable what horrible products honestly. So disappointed in these because of the unreliability and downtime ?

    0
    Comment actions Permalink
  • dylanunderhill

    My X4's are having the exact same issue. Really disappointing because I take exceptional care of my headphones and they still break down. This has really impacted my view of this brand....

    0
    Comment actions Permalink
  • BMinor

    To further my comment from a coupe days ago.....I will got to say the person I have had that deals with customer support has been great! They have replaced the headphones Everytime (that part is really bad) quickly and even upgraded me twice now waiting for run XT to arrive. Got the email yesterday, three days after I emailed support. Also my brother has purchased around 7 pairs of these over a six month period for himself and other friends and family and none of them have any issues so what's up with that. I take extremely good care of things. Of course I'd have just rather had my original headphones work. I'm worried about the Run XT buds now and I haven't received them yet.

    0
    Comment actions Permalink
  • Avanish

    My freedom 2 headphones right channel near the mic stopped working suddenly, please help and I stay in India how to get replacement while jaybird is not in india

    0
    Comment actions Permalink

Please sign in to leave a comment.