X3’s have stopped working

Comments

10 comments

  • PNG18

    Same here except the light on my charger is red! What's the deal with these headphones??! They won't even turn on!

    0
    Comment actions Permalink
  • Sohil

    Yeah I am also facing similar issues and mine are less than 6 months old

    0
    Comment actions Permalink
  • PNG18

    I emailed customer support to advise next steps. Looks like this is a common problem. Will let you both know what the response back is. 6 months in and the headphones died? That’s unacceptable.

    0
    Comment actions Permalink
  • DeckerJJD

    Thanks, PNG18 - hope it is a relatively simple fix/solution. That being said, I am hoping to hear directly from Jaybird about this, as I assume someone is monitoring these boards. I've had my X3's for about 8 months.

    0
    Comment actions Permalink
  • PNG18

    Guys,

     

    Just received a cut and paste stock answer to our dilemma. See below.

     

    I am sorry to hear that your Jaybird X3 won't turn on. I can assure that this is not the behavior and performance expected from the product. Please try these suggestions that can help to resolve the issue of your headset:

     

    - Computers are the best and safest method, as is anything 1 AMP or less.

    - Try a different power source/charger

    - Car chargers produce a much greater power supply and should be avoided.

    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2.5 hours,

    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.

    - Avoid charging your headphones after exposure to sweat.

    - Make sure charging port/cradle is clear of any debris.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

     

    0
    Comment actions Permalink
  • Mario3435

    I'm having the same issue and I notice they always have the same answer! What is happening? I always trusted Jaybird, and it seems they are not the same!

    0
    Comment actions Permalink
  • PNG18

    I wrote back to Jaybird_Bruce who seems to be the one supplying these stock answers. See below. I'll keep you guys posted.

     

    Hi Jaybird Bruce,

     

    Thank you for providing those suggestions. Unfortunately none of those suggestions have helped me. My headphones still will not turn on. Surely other customers have complained about the same issue. It looks to be a common problem among X3 users. What else do you recommend?

     

     

    Thanks,

    Paul

     

     

     

     

    0
    Comment actions Permalink
  • DeckerJJD

    I also emailed customer support, but have received the same information as you so far. I will post here if I get anything different.

    0
    Comment actions Permalink
  • PNG18

    Thanks Decker. I’ll do the same! This is ridiculous!

    0
    Comment actions Permalink
  • DeckerJJD

    Today my contact with customer service asked for some additional info from me, including proof of purchase and serial number of the headphones in order to continue processing my warranty claim. Not sure if this means they will be shipping me a new pair or what, but will post here with any additional information/resolutions.

    0
    Comment actions Permalink

Please sign in to leave a comment.