Jaybird X3 right side stopped working

Comments

4 comments

  • Logi_Bruce

    Hi sanemeth,

     

    I am sorry to hear that you are experiencing an audio issue with your Jaybird X3's. This is not the quality we're expecting from our product.

     

    Please isolate the issue by testing using a different device or a device with a different OS and checking the voice prompts if it plays on both sides.

     

    Feel free to reach out back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • sanemeth

    So tried connecting to my mac and no luck. Also the voice prompts for power on power off are only coming out of the left ear.

    0
    Comment actions Permalink
  • BenCas

    I am having the exact same issue with my X3s. The left side stopped working out of nowhere after I finished charging them?

    0
    Comment actions Permalink
  • Logi_Bruce

    Hello sanemeth and BenCas,

     

    Sorry to hear that it did not work. I sent an email from us regarding your concern and how we will be proceeding.

     

    Feel free to reach out back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink

Please sign in to leave a comment.