RUN sound Quality poor post update, really Terrible.

Comments

13 comments

  • respa

    Hi Sahilgaurkar,

     

    Thank you for posting here in the community. Sound quality is a key focus in our product development process. We use high quality components and standards to ensure optimal audio performance. Jaybird RUN uses the recommended Bluetooth Standard parameters to encode and decode audio played by the source device. The quality of the audio is dependent on the source device (type of phone, tablet) as well as the audio source quality (e.g. streaming quality on Spotify or other services).

     

    Feel free to post back in the event that you need further assistance.

     

    You can also reach us via other channels at https://www.jaybirdsport.com/en-us/support.html

     

    Best Regards,

    Jaybird_Axel

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Sahilgaurkar
    I am using the same phone before updating the buds that is on v1.0.4 the sound quality was excellent but after updating the buds to v1.1 and with the same phone the sound was distorted. I am using iPhone 7 plus. Please help.
    0
    Comment actions Permalink
  • Sahilgaurkar
    I tried resetting the buds but still no changes in sound. I even restart my phone but nothing changed.
    0
    Comment actions Permalink
  • UltraMind

    many users feel the same issue.

    but JayBird do nothing...

    Please help JAYBIRD. Sound Quality is terrible. High range sounds are distortion.

    0
    Comment actions Permalink
  • Sahilgaurkar

    @kiyoung Jung? I am having the same problem after the update.

    Which phone are you using it with, and its software version?

    0
    Comment actions Permalink
  • adrnt

    me too.. and many others in this forum. Still not addressed by jaybird.

     

    0
    Comment actions Permalink
  • Jeffay
    I am using firmware 1.1 with my iP8+, the high range sound quality is terrible. I listen the same song with Apple Music App in my HTC 10 which is good and no issue. Jaybird team can address the problem?
    0
    Comment actions Permalink
  • cdoyle323

    Has there been no update on this? I just bought these yesterday after hearing all the rave reviews about the sound quality and now I find with 1.1.0 the sound quality is worse than with my $20 wired buds. We need an update ASAP or this will be the last Jaybird product I buy. Extremely disappointed.

    0
    Comment actions Permalink
  • xarons

    wow, I see this post was over a month ago... and the distortion while listening to music hasn't been fixed, I just my SECOND set, and they both had the staticy issue... i'm using google play, which on EVERY other device sounds 100% perfect (most everything I own is wireless since I have an iphone 8plus and don't want the converter plug) and the RUNS have/are the only thing with CRAZY static while listening to music. I'm within my return period, and might switch to the Bragi's if this isnt going to be fixed... and it appears jaybird is blaming other things instead of their update....

    0
    Comment actions Permalink
  • Sahilgaurkar

    Its been 3 months since that static problem, Still no update available.

    WHAT IS THE FIRMWARE TEAM DOING???

    0
    Comment actions Permalink
  • Reebs

    These are awful. Just awful. I bought them yesterday. I can’t talk to anyone without awful distortion. I can’t listen to music consistently without distortion. They have no answer? I’m taking them back. That’s my answer.

    0
    Comment actions Permalink
  • ChristopherRoberts2827

    I originally bought a pair of RUNs in January from Amazon that had the same issue as described above. Went through 3 different pairs, all with the same issue. I left a review on Amazon describing my experience. Someone from Jaybird reached out to me to get more details about the issues going on. They set up a phone call for me to talk with one of their sound engineers who asked a ton of questions in hopes of being able to recreate my listening experience. About a month after this phone call with the sound engineer I received some "special" RUNs that should have taken care of the issue, but didn't. I replied back to the CS person I've been working with, but I was told that they haven't been able to recreate the issue, which is odd since it appears I'm not the only person experiencing terrible sound quality. Overall, I've been through 5 different pairs of RUNs and all sound terrible, and no solution has been presented to me.

     

    Although it may not sound like it, I will say I have been very pleased with the customer service that Jaybird has provided to me. They have been extremely nice and professional in every dealing I've had with them. I just wish the RUNs weren't such a terrible product. I'll just stick with my X3's, which are amazing.

    0
    Comment actions Permalink
  • Patr3264

    I've signed up because this apparently is a widespread problem, which is not being addressed (quick) enough.

     

    Primary choice for the X2, multiple Freedoms an X3 and now the RUN has always been SOUND QUALITY.

     

    I've seen overall built quality decrease - being a pro/heavy user - this is an undeniable fact I learned to deal with - but this latest sound quality issue is making it really hard to keep the faith and stay positive towards this company....

     

    Especially since you've made it increasingly hard to RMA (from Europe) which I needed to do on a 5 month old X3.....and bought this RUN, as replacement.

     

    Come on guys, We're the ones speaking out, because we care - It would be nice, decent, respectful, marketing-savvy and 'a lot more, if you help us out and AT least keep us posted with regards to progress / development of a firmware that will sove this - or at the very least - give us the choice to downgrade!

    0
    Comment actions Permalink

Please sign in to leave a comment.