Freedom 2 not pairing with devices

Comments

3 comments

  • Bruce

    Hi Fletcad,

     

    Thank you for joining the community and for posting your query. I can definitely help you with this one.

     

    Can you try and reset your source device prior to re-pairing? You can also forget the Jaybird Freedom 2 from your Bluetooth list.

     

    Please also check if the Bluetooth list has room to remember the Freedom 2. Lastly, you can test pairing the Freedom 2's with a different device or a device with a different OS.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Fletcad

    Thanks for the response.

    I've tried all of those things - I have reset my phone and iPad multiple times and 'forgot' the headphones from the list. I only have one other thing paired to each device so the list is not full.?

    0
    Comment actions Permalink
  • Fletcad

    Hi,

    Just following up on my response from earlier this week. I have continued to try all the options you suggested but nothing has worked.

    Do you have any alternative fixes or is it possible to get them repaired/replaced?

    Thanks

    0
    Comment actions Permalink

Please sign in to leave a comment.