I've had my Freedom's for about 1 year and now, without warning or reason, yesterday they started skipping back to the start of tracks repeatedly and the volume kept dropping on it's own.

Comments

2 comments

  • Bruce

    Hi Sassyruss,

     

    I am sorry to hear that your Jaybird Freedom skips tracks and drops volume. This is not the quality we're expecting from our product.

     

    Here is a list of steps for the Factory Reset:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.

    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

     

    You can further isolate the issue by testing using a different device or a device with a different OS.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Sassyruss

    Hi Bruce, thanks for the reply.

     

    I have done a factory reset numerous times and unfortunately, it has not worked. I'm wondering, if the battery has run it's course, would that affect the performance of the earbuds? The fact that it won't even connect to my device anymore is very frustrating!

    0
    Comment actions Permalink

Please sign in to leave a comment.