IPhone App not connecting to X3

Comments

10 comments

  • rdavis.ubc

    I am also having trouble. Have tried the suggested ways in which to sync offered in this forum... nothing works. Operating an iphone 6 with iOS 10.2.1... What's the point of the X3's without the MySoundApp... should have purchased the X2's. Frustrated.

    0
    Comment actions Permalink
  • Madi

    Hi there,

     

    Please be aware that there have been some recent updates to the MySound app which should help with connectivity issues. Please make sure to update your app to the latest version and you should have a better time with getting connected to MySound!

     

    Please let me know if this does not resolve the issue.

     

    -Madison

    Jaybird Customer Experience

    0
    Comment actions Permalink
  • beeeesiang
    Hi Madison, I am also experiencing the same issue. I need to reset my x3 everytime before it can connect to mysound app even though it is already connected to my phone. Downloaded the app on 11 Aug, it should be the latest version? How can I solve it? Pls help!
    0
    Comment actions Permalink
  • Madi

    Hi there,

     

    Sorry to hear about the trouble you've been having, you definitely shouldn't need to reset each time you connect to the app! Some things you can try:

     

    • The control panel is where the antenna is so try keeping the side with the control panel on the same side as your device.

     

    • If you wear them over the ear in the Xfit style I've found it can affect the connection quality.Try wearing them in the under the ear style instead and it can improve your connectivity.

     

    If you're still having the same trouble please contact our support team and they will be able to get you taken care of. You can call us at: 1.866.244.3399

     

    You can also find us on Live Chat or Email at: https://www.jaybirdsport.com/en-us/support.html

     

    Hope this helps!!

     

    -Madison

    Jaybird Customer Experience

     

     

    0
    Comment actions Permalink
  • beeeesiang
    I wear them in the under the ear style and also ensure that the x3 and app pairs with close distance without blockage but the app still couldn't connect to the x3. Is it a product issue?
    0
    Comment actions Permalink
  • Madi

    Hi!

     

    Thanks for your feedback, I am going to forward this feedback to our devs so that we can look into this further for you. I will let you know when I get any additional feedback for troubleshooting that you can use to resolve this.

     

    Madison

    Jaybird Customer Experience

    0
    Comment actions Permalink
  • beeeesiang

    Found out that I shouldn't long press the on/off button after pairing - it will keep re-pairing. My bad. Issue is resolved and product works fine now. Thanks for the help!

    0
    Comment actions Permalink
  • alxmasha

    Hey @Madison Farnsworth? , I seem to be experiencing the same issue. I have an iPhone 7 and the app isn't connecting. Has this issue been resolved and if so how can I resolve it on my end. Thanks in advance.

    0
    Comment actions Permalink
  • respa

    Hey Guys,

     

    I would like to give some suggestions that can help with your concerns for the headset that not connecting on the Jaybird App.

     

    Please follow the steps below.

     

    Turn off and turn on Bluetooth again in the 'Control Center' (NOT in the 'Settings'). The Bluetooth button is the one at the top left of screen. You can get to the Control Center by swiping up from the bottom of the screen (swipe down from top right on iPhone).

     

    Again, its important that your not turning off and on the Bluetooth in Settings. you'll need to do it in the "Control Center", otherwise the issue will remain.

     

    Hope this helps!

     

    Best Regards,

    Jaybird_Axel

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • alxmasha
    @Romil Español thanks for this, it’s finally connecting no problems.
    0
    Comment actions Permalink

Please sign in to leave a comment.